Nerdio Managerのアップグレード時にIntune Insightsエラーが発生します

Nerdio Managerのアップグレード時にIntune Insightsエラーが発生します

Nerdio Managerのアップグレード時に、Intune Insightsを使用しているときに500(内部サーバーエラー)に遭遇する可能性がある既知の問題があります。

次の2つの領域でHTTP 500エラーが発生する可能性があります:

  • Intune Insightsを起動する際。

  • Intuneの同期プロセス中(手動で実行しても)。

原因

この問題は、IISアプリケーションの起動シーケンス中にデータベースのアップグレードステップがタイムアウトした場合に発生する可能性があります。タイムアウトにより、システムが不整合な状態になる可能性があり、更新されたスキーマに依存するコンポーネントにアクセス時に500エラーが発生します。

回避策

この問題が発生した場合は、回避策の手順に従って手動でアップグレードプロセスを完了できます。

回避策を実施するには:

  1. Azureポータルに移動し、サインインします。

  2. Intune Insightsを実行しているWeb Appに移動します。

  3. 設定セクションに移動し、矢印を選択して展開し、次に環境変数を選択します。

  4. アプリ設定セクションで、WEBJOBS_IDLE_TIMEOUTを検索します。そして、値を3600に設定します。

  5. 適用を選択します。

    注意:WEBJOBS_IDLE_TIMEOUT設定が存在しない場合は、それを追加し、値を3600に設定する必要があります。

  6. 再度適用を選択します。

    注意: 確認されると、Webアプリが再起動されます。

  7. WebJobs タブから、DatabaseMaintenance というタイトルのジョブを見つけて、実行 アイコンを選択して手動で実行します。

これで、500エラーを解決するアップグレードプロセスが完了しました。

この記事は役に立ちましたか?

0人中0人がこの記事が役に立ったと言っています
他にご質問がございましたら、リクエストを送信してください

コメント (0件のコメント)

サインインしてコメントを残してください。