Alerts for Azure capacity extender

It would be nice if we could get an alert if the azure capacity extender had to run, what machine or host pool and what sku.
 
1

Comments (1 comment)

1
Avatar
Justin Miller

Agreed. We've just setup an alert in azure to fire off when there isn't capacity. 

AzureActivity
| where OperationNameValue == "MICROSOFT.COMPUTE/VIRTUALMACHINES/START/ACTION"
| where Properties contains "We do not have sufficient capacity for the requested VM size in this zone"
//| summarize count()
//| mv-expand Properties
| mv-expand parse_json(Properties)
| where Properties.resource contains "c"
| project TimeGenerated, tostring(computername = Properties.resource), ResourceGroup
| summarize count() by ResourceGroup, computername
| sort by count_ desc 

 

Please sign in to leave a comment.